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Define a Project 
 
Define a project: Objectives: Clear project objectives are crucial because project 
               success will be determined by how closely you meet 
      them. A clear project objective is both specific and 
      measurable. Avoid vague objectives such as “Create a 
      state of the art learning environment”. Objectives may 

     include: 
     Deliverables 
     Milestones 
     Specific due dates 
     Quality criteria 
     Cost limits 
    For objectives to be effective, it is important that all 
     Stakeholders officially agree to them. 
 
  Assumptions: During the planning stage there will be many  

unanswered questions, such as “When will key 
resources be available and how much time a new process 
will take?” To begin you make educated guesses and then 
use those estimates to create your schedule. Areas where 
assumptions arise: 

1. Handoffs from other departments. If your 
project depends on the work of others do they 
understand your dependency and agree to hand-
off dates you expect? 

 
2. Resource availability and usage. If you do not 

manage some of the people who does and have 
they approved your use of their resource. 

 
3. Task durations. Are your estimates based on 

solid information or guesses? 
 

4. Project costs. How important is cost to your 
project? 

 
5. Available time. Can you realistically complete 

tasks on time with acceptable quality? 
 

6. Deliverables. Does your deliverable match what 
you stakeholder expects. Get agreement. 

 
  Constraints: Constraints on a project are factors that are likely to 

   limit the project manager’s options. The three major 
   constraints are:  
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   Schedule: fixed dates, deadlines and 
    milestones. 

 Resources: People, materials, facilities and  
Equipment. 
Scope: The project requirements change. 
 

   Scope:  A combination of all project goals and tasks, and the 
      work required to accomplish them. Scope 
      management is a procedure for handling changes to 
      your project. A plan may include: 
 

An assessment of how likely and often the scope 
will change. 
 
A description of how scope changes will be 
identified and classified. 
 
A plan for scope change. Notify the sponsor and 
issue a change order. 
 

   Deliverables: A tangible, verifiable outcome of work. It must meet 
      Predetermined standards for its completion. Is “I want 
      a product that works” a good deliverable? 
 
     Deliverables have stakeholders. The stakeholders 
      Must accept the finished state of the deliverable. 
 
     Deliverables have an agreed upon grade and quality 
      that set appropriate expectations for its completion. 
 
     Need to create a schedule focused on deliverables. 
      They include: 

A separate phase with one task: With a milestone to 
represent completion. 
 
A group of tasks in a phase. Can schedule a team to 
work on the phase, such as “all routine maintenance 
task”. 
 
A group of deliverables. Worked on during the 
same time period, by different groups. 
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Project Plan Activities 
 
Start a project file 
1. Open a file  New:   Open MSProject application or if it is already open click on 

the “new blank document” button (top left). 
 

   Existing: Click on open file (second from top left). Open file or 
Template 
 

2. Enter file properties  On the file menu, click properties, then click 
summary tab. 
 

3. Set project calendar   On tools menu, click Change working time. In the  
for box, click project calendar. 
 
To change one day for the entire calendar click on that day 
and change time by clicking “nondefault working time” and 
then entering the new times. Click “non working” if it is a 
holiday or some other day off from work. 
 
To change two or more random days click on each day 
while holding down the “Ctrl” button to highlight the days 
to be changed. Change time by clicking “nondefault 
working time” and then entering the new times. Click “non 
working” if the days are a holiday or some other day off 
from work. 
 
To change one day of the week for the entire calendar  
click abbreviation at top and change time by clicking 
“nondefault working time” and then entering the new 
times. 
 
To change all working days click abbreviation at top, 
hold down the shift button and highlight the days to be 
changed. 
 
Note about individual resource calendars. Put “Jim” in  
resource table. Go back to “Change working time” and 
show Jim’s calendar. 
 

4. Enter project information  On the Project menu click Project information.  
 
Outline tasks 
1. Enter important tasks:  

New    In the Task Name field type a task name. Press enter. 
     You can organize your tasks as you enter them or wait 
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      until they are all entered then organize them. 
      
     Note: you can enter a task between existing tasks by 
      selecting the row below where you want the new task. 
      On the Insert menu click New Task and enter the 

 task name in the inserted row.  
 
 Reoccurring   Highlight the row where a reoccurring task is to be entered.  

In the Insert menu click Recurring Task. The Task 
    Information box will appear. First enter your task 
    name. Enter: 

       Task name 
Duration 

       Frequency 
       Date 
       Range 
       Calendar 
 
2. Create summary & sub tasks:  
 Summary tasks  In the Task Name field click the first task that you 
     want to be a sub task. On the Insert menu click New  

Task. Type the name of the summary task and press enter. 
Select the task(s) that are to be subtasks (if more than one) 
press ctrl and then click each task. Click Indent  to 
indent task(s). 
 

Sub task Enter or select tasks that are to be sub tasks under the 
summary task and Click Indent  to indent task(s). 

 
3. Supporting info Click on task (or icon on toolbar) for task information. 

   General:  
    Name of task 
    Duration (? Is estimated) 
    Percent complete (tracking) 
    Priority 
    Dates 
   Predecessors 
    Linking to other tasks 
     FS 
     SS 
     FF 
     SF 
    Lag (FS with + will delay start 
     by lag time) 
   Resources 
    From resource table or enter 
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   Advanced 
    Constraints 
    Constraint type (eight types) 
     Flexible 3 (duration only 
     set) 
     Semi-flexible 3 (soft)  
     Duration can’t change but 
     start or finish date can  
     (has a start or finish 
      boundary). 
     Inflexible 2 (hard) must  
     begin or end on a certain  
     date 
    Task type work = duration x units 
     Fixed units (default) 
     Fixed duration 
     Fixed work 
   Notes  
    Enter important info about a task. 

 
Task Organization:  
1. Link tasks      To link a two tasks; 
        If nonadjacent – highlight first task  

press CTRL and highlight second 
task. Then click the link icon. 

 
        If adjacent – highlight first task 
         press SHIFT and highlight second  

task. Then click the link icon. 
 

To change a link – Click on link line and 
type what you want in the Task 
Dependency box. 

 
2. Move tasks (copy and delete)   To move a task click Cut Task. Then  

Highlight the row where the task is to be  
placed and select paste. (or highlight the row 
to be moved, then left click once and hold 
down while you move the line that appears 
to the new row for the task). 

 
       Note: It is best to move tasks before 
        Establishing task dependencies. MSP will 
        reestablish task dependencies. It will also 
        move subtasks, notes, and linked or 
        embedded objects. (you can manually 
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        prevent this operation (Tools, Options, 
        Schedule, clear Autolink). 
 
3. Split a task      Click Split Task. On the task’s Gantt bar, 
        click the area of the bar where you want the 
        split and drag the second part of the bar to 
        the date the date that you want the work 
        to begin again. 
 

Note: WBS organizations   The hierarchy of tasks in your project. 
 
Estimated task durations 
1. Estimate & enter a duration.   In the duration field, type the duration you 
        want. 
 
2. Change a task duration    Click on the duration box and use up & 
        down arrows or type in a duration. Can also 
        be changed in the Task Information box. 
 
3. Create milestones     Type 0 in the duration field. Some 
        milestones will have a duration. For 
        example, task with an approval process that 
        will take a week 
 
4. Start & end date     Click on the start or finish box and use the 

  calendar to enter a date or directly enter a  
date into the box.  

 
Set task dependencies &constraints 
1. Create a deadline     When you want to track a deadline for a 
        Specific task but don’t want to lock your 

    Schedule by setting an inflexible constraint 
   you can set a deadline date. Click Task 
    Information  & Advanced. Click Deadline  
 

2. Tie a task to a specific date    When you have unavoidable constraints, you 
        Can tie a task or phase to a specific date. 
        Select Task Information & Advanced. In 

     the constraint box, MSP sets 1 of 8 types of 
constraint. 

 
Assign resources 
1. Enter resource names    Go to the Resource Sheet. Enter resources in 
        the table. Several fields appear including; 
        Type 
        Max units 
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        Accrue at 
        Base calendar 

 
2. Add notes about resources    Like the Gannt Chart with a Task 
        Information box the resource sheet has a 
        Resources Notes box. To open it double 

click on the row you want information  
about. It includes. 

        General 
         Enter start and end dates and  

percent available. 
        Working time 
         Set up individual calendars 
          for a single resource or 
          groups. 
        Costs 
        Notes 
 
3. Assign a resource     In the resource field of the Gantt chart enter 

the name of resource, or select from those 
already entered. 
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Advanced Project Plan Activities 

 
Optimize the Project Plan 
Critical Path      A critical path is the series of tasks that will 
        push out the project’s end date if they are 
        delayed. The word “critical” has nothing to 
        do with how important these tasks are to the 
        overall project. A key to understanding the  

critical path is to understand slack, known   
as float. There are two types of slack; free & 
total. Free Slack is the amount of time a 
task can be delayed before it delays another 
task. Total Slack is the amount of time a 
task can be delayed before it delays the 
finish of the project. A task is on the critical 
path if its total slack is less than a certain 
amount, normally zero. To view critical 
tasks in the View menu select more views. 
In more views select Detail Gantt and click 
apply. (critical tasks are in red, non critical 
in blue). 

 
Review costs and dates    If resources are not assigned then you can 
        only track durations and start and finish 
        dates.  
 
       If resources are assigned then to update 
        remaining work click on the Tools menu 

  then click Tracking and Update Tasks.  
 

Identify over and under allocated resources  Once your have built your plan you can 
        review how well your resources are used to 
        handle over allocation. 
 
       Example: Enter new project with task 1 and 
        task 2. Set duration to 3 days for both  

tasks. Enter Jim and Tim in the Resource 
        sheet. Select Tim for both activities (Watch 
        move). Undo entry 
 

For task 1 put a constraint must start 
      on first 2/6/01. Set task 2 to Start no later 
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      than 2/5/01. Put Tim in for task 2. Watch 
   split. 
 

Baseline a plan     A baseline is a snap shot of your plan that 
        Saves start & finish dates, resources and  

assignment values.  
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